Author Message

Posted: Wed Jul 17, 2013 7:35 pm   Post subject: issue with ispring output in Moodle and IE8

Hi,

I bought ispring pro7 and did the follwing

- exported a ppt with ispring pro 7
- embedded it as file ressource into moodle 2.5
- accessed it with IE 8 first time --> ok!
- browsed to another page within moodle
- went back to the embedded ispring resource --> empty frame
- push reload button of browser: frame appears


I think the problem is in the player js. If I set the "SWF" file as the main file (instead of index.htm), it loads all fine (of course then the problem is that links for exmaples then do not work etc.)

Hope you can help me!

Suren


Profile profile test

Posted: Thu Jul 18, 2013 8:28 am   Post subject: Re: issue with ispring output in Moodle and IE8

Please Publish to LMS with SCORM compatibility and then upload it as a learning course to Moodle.

If you want to publish a regular Flash to your Moodle system please check All in one Flash file at the General tab and uncheck all marks for Detach media at the advanced tab.
iSpring will save everything to a single Flash file ready for uploading to your LMS.


Profile profile test

Posted: Fri Jul 19, 2013 4:22 am   Post subject: Re: issue with ispring output in Moodle and IE8

Thanks you very much for your fast reply!

Yes, the problem does not appear if I integrate the ispring output as scorm activity.

The second solution does not work (export as single swf). I tried with the settings you suggested but the problem is still there.

Btw: I analyzed the output and there is not only one single flash file but also a data folder with js inside. Is that correct?

Thank you very much for your help.


Profile profile test

Posted: Fri Jul 19, 2013 1:12 pm   Post subject: Re: issue with ispring output in Moodle and IE8

When you are publishing all in one with iSpring 7 you will get a data folder but Flash presentation will be still self-functioning.
Image
Probably it's a Moodle's drawback that it requires Flash manual reloading before showing it again.


Profile profile test

Posted: Sat Jul 20, 2013 3:50 am   Post subject: Re: issue with ispring output in Moodle and IE8

We have links to external websites in our presentation and donˊt work if I only run the flash file on (on the server).

Did we do sth. wrong?


Profile profile test

Posted: Mon Jul 22, 2013 1:57 pm   Post subject: Re: issue with ispring output in Moodle and IE8

Links could not work when opening Flash from the local destination due to global security policy. However, you are telling that the presentation is placed on the server so I believe it's in the Internet. In this case refer to the following troubleshooting information:
- If you don't see hand pointer when hovering a mouse over the link it means that it's not working. Possible reason: a style had been implemented to a text of the hyperlink, and it got converted to a still image in Flash rather than text and therefore it doesn't work.
- Also it's possible that links were not assigned properly

To help us understand this problem better you can attach a link to your presentation or contact us at support email. Thank you.


Profile profile test

Posted: Fri Feb 28, 2014 12:24 pm   Post subject: Re: issue with ispring output in Moodle and IE8

Hi,

we have tried several workarounds and now I am back at this problem and what you have described does not work. If I use the single flash file on a server, the links will not work. Only if it there including the index file, but then it will not work in moodle 2.5 with IE8 as described above. I will now you a mail with the files attached.

UPDATE/CLARIFICATION:

If I use above flash just on the server (not in moodle) the links work. But if I integrate it as FILE resource or LINK ressource, the links will not work. So it maybe is a moodle setting? which one could it be if so?

Thanks a lot!


Profile profile test

Posted: Sat Mar 01, 2014 4:07 pm   Post subject: Re: issue with ispring output in Moodle and IE8

I have found the reason and a solution.

The reason why the links in the flash movie won't work in moodle is related to some security settings explained here:

http://helpx.adobe.com/flash-player/kb/ ... ction.html

There is also explained the solution.


Profile profile test

Posted: Thu May 22, 2014 10:41 pm   Post subject: Re: issue with ispring output in Moodle and IE8

Dear customer,
Thank you for the post and for this very useful link!
I hope it'll be very helpful for those who use iSpring and Moodle LMS.


Profile profile test

Posted: Tue Jul 08, 2014 1:57 am   Post subject: Re: issue with ispring output in Moodle and IE8

Very helpful and good solution, thanks, iSpringer !


Profile profile test
Display posts from previous:  Sort by  

  


Who is online
Who is online In total there are 3 users online :: 2 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 108 on Thu Nov 21, 2013 3:41 pm

Registered users: Baidu [Spider], Bing [Bot]