Author Message

Posted: Wed Feb 19, 2014 4:36 pm   Post subject: Player Nav. Bug for Presenter 7 in Google Chrome

I am using iSpring Presenter 7 to create a presentation that is being published using combined HTML5 and Flash with SCORM 1.2 for use in an LMS.

When I view the published Flash presentation (the index.html file) using Google Chrome (both in the LMS and independent of it) there is an inconsistent but frequent problem with the Next and Prev buttons in the iSpring player skin. Oftentimes, when I click the Next or Prev button with my mouse nothing happens on click. I have to click the button and then move my mouse off of the button before the slide will advance or go back, as appropriate to the button. Sometimes the course will advance normally for a few slides and then the error will occur again. It switches back and forth between working and not. It does not seem to happen/ not happen on any particular slides between one test viewing and another. I do not believe that it is any sort of slide loading issue because how long I wait after an "unsuccessful" click does not seem to matter, but as soon as I move my mouse off the button the slide changes.

The Outline button in the player skin works just fine and does not display this behavior. I have tested the HTML5 and Flash versions of the published presentation in Google Chrome (version 32.0.1700.107 m), Mozilla Firefox, Internet Explorer, and Safari for PC. The HTML5 version of the course does not display this behavior at all and is functioning normally. This problem is only in the Flash version of the published presentation when viewed in Chrome.

I created an earlier prototype of the same course several months ago (before my most recent Chrome update) that was put onto the same LMS. It did not exhibit this problem. If I go back and launch that prototype presentation in Chrome now, it displays the same behavior reported above.

Please let me know if there is a work around, fix in progress, etc.


Profile profile test

Posted: Tue Mar 18, 2014 9:14 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

So, I'm back again.

In order to get around the navigation issue, the course was uploaded to the LMS as HTML5 only, no Flash. That has resolved the navigation issue.

There is, however, another problem. The HTML5 version has text spacing issues when viewed in Chrome and Safari (for PC), but not on FireFox or Internet Explorer. Some words in the body copy text are in red to draw attention to them. They are not bolded, nor italicized, nor do they have a shadow or any other effects on them. But for some reason, these words have twice (sometimes more) the space between them and the words next to them as the black body copy text, which is exactly the same except for the color.

These text spacing issues appear both inside the LMS in question, and when run locally outside the LMS.

The text appears to be fine in the iSpring work environment and in the slide show mode.

How can I address this?


Profile profile test

Posted: Mon Mar 24, 2014 7:30 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

Probably Flash can't have a focus when opened in your LMS. It has to be tested specifically.

HTML5 text may appear slightly different on different browsers. There is a workaround: apply any text effect (e.g. Glow) to problematic text boxes with transparency 99, which will save text as raster images and will look the same in all browsers.

This article may shed some light on this issue:
http://www.ispringsolutions.com/kb/faq/ ... -ipad.html


Profile profile test

Posted: Tue Mar 25, 2014 6:23 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

Unfortunately, your response was not helpful.

The linked article relates to problems with iPad specifically, whereas this issue is occurring on a desktop. And, as the article itself says, "On your desktop computer, fonts in your HTML5 presentation will look just as they do in PowerPoint." They do not look the same.

I did try adjusting the text fill (since the text color by itself is not classified as an "effect" by PPT) of the problem words to 99% Transparency, but that makes the text invisible to the eye. I then tried the opposite, and set it to 1% transparency. The text was still visible but there was no change, the formatting error still occurs after the presentation is published.

I have run several additional tests and now have reason to believe that it is not purely a Google Chrome issue, but a compatibility problem between iSpring and the version of Chrome on my computer (Version 33.0.1750.154 m). The tests I ran using a different authoring tool did not have this formatting issue.


Profile profile test

Posted: Fri May 23, 2014 9:02 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

Dear Jen,
Thank you for your post!
Actually we added several improvements for processing fonts in different browsers.
Let me please recommend you to download the latest build from our website and check if it helps with this problem.


Profile profile test

Posted: Fri May 23, 2014 9:39 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

Thank you for replying. I imagine the downloads would only apply to courses published after they've been applied in iSpring, is that correct?


Profile profile test

Posted: Mon May 26, 2014 8:53 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

Dear Jen,
Yes, you are absolutely right. As soon as you install the latest iSpring updates, please convert the presentation one more time with the new product build.
I hope it helps!


Profile profile test

Posted: Wed May 28, 2014 7:59 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

Julia,

Thanks for confirming. I'll give it a try when time allows.


Profile profile test

Posted: Wed Jun 04, 2014 3:44 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

I downloaded the latest version of iSpring Presenter 7 (version 7.0.0.5521), as per Julia's suggestion, and it has solved the spacing problem with the red text when viewed in Google Chrome.

Bold text comes across as either fuzzy or thin/narrow, which was a lesser issue I'd run into, but the main problem has been resolved.

Thanks for the responses.


Profile profile test

Posted: Thu Jun 05, 2014 1:14 pm   Post subject: Re: Player Nav. Bug for Presenter 7 in Google Chrome

Dear Jen,
Thank you for letting me know about it.
I am glad to hear that a new build resolved the problem.


Profile profile test
Display posts from previous:  Sort by  

  


Who is online
Who is online In total there are 5 users online :: 1 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 108 on Thu Nov 21, 2013 3:41 pm

Registered users: Bing [Bot]


cron