Author Message

Posted: Tue Jun 21, 2011 9:34 pm   Post subject: How to disable hotkeys the same as language-specific letters

Letter ó and ń is typed on Windows by pressing right Alt and o (n) simultaneously. Unfortunately, this also launches iSpring Quiz Maker exit dialog box. How to disable this hotkey?


Profile profile test

Posted: Wed Jun 22, 2011 2:44 pm   Post subject: Re: How to disable hotkeys the same as language-specific letters

Hi, thank you for your post.

iSpring QuizMaker doesn't have it own customizable hotkeys as it obeys standard Windows hotkeys set in your system. You can settle the issue changing the standard key combination for "close an active window" command on your computer if it is possible in your version MS Windows.


Profile profile test

Posted: Wed Jun 22, 2011 5:57 pm   Post subject: Re: How to disable hotkeys the same as language-specific letters

On this page are Windows Vista shortcuts:
http://windows.microsoft.com/en-US/wind ... -shortcuts . On this page I found Alt+F4 and Ctrl+F4 to be related to closing windows. That's indeed the case in my system.

However, my problem is with ó and ł , which are RightAlt+o and RightAlt+l , which as a result are the same as Ctrl+Alt+o and Ctrl+Alt+l (I just tested it). Those are surely not any Windows shortcuts and I never had this issue with any other program (and I have quite a few on my computer) except Captivate (just not sure which letters were affected, perhapse the same). Captivate support admitted there are exactly these hotkeys defined in their software, but they do not plan to enable hotkey reconfiguring, which was one of the many reasons I resigned to use it.

I don't know what makes the closing dialog appear in iSpring after pressing Ctrl+Alt+o and Ctrl+Alt+l, but this is not a global Windows hotkey.


Profile profile test

Posted: Thu Jun 23, 2011 12:17 pm   Post subject: Re: How to disable hotkeys the same as language-specific letters

It seems that these key combinations are built-in to your system. iSpring QuizMaker doesn't have the preset to close the dialogue window for Ctrl+Alt+o and Ctrl+Alt+l. E.g. on a Windows 7 machine the combination Ctrl+Alt+o is a default hot key for opening a file and it doesn't close the window.

Perhaps it would be more easy to change the shortcuts to symbol if they are editable in your system. Please view this useful article on this topic:

http://www.compukiss.com/basics/symbols-character-map-2.html


Profile profile test

Posted: Thu Jun 23, 2011 3:40 pm   Post subject: Re: How to disable hotkeys the same as language-specific letters

Changing the "hotkey" of ó and ń (because it is in fact ń and not ł, sorry my bad) would be as much counterproductive as clicking the mouse to close the dialog box each time it appears. These are quite frequent characters from Polish language and.. well, that's not the way to deal with this, it is as if I had to always type x instead of y for some reason. Or better yet, prepare the questions and answers in Notepad and paste them to Quiz Maker. Sure can do, but it's slow and ugly solution.

Some additional info:
1. as I already mentioned, *no other* program on my computer and on any computer that I used ever had this issue, except for Captivate, which admitted they had a hotkey for these character combinations.
2. I just installed iSpring demo on a laptop and voila, the same problem
3. I changed the keyboard (Control Panel->Regional and Language->Keyboard->Change Keyboards) to US International instead of Polish Programmer as it was before and the problem persists.

If you say that iSpring for sure does not have this hotkeys assigned to anything then it's really strange. I have a feeling that it might have something to do with language settings, but no idea what really.

[Update]
I installed iSpring Presenter demo and it has the same problem. Additionally I discovered that it is sufficient to press Ctrl+o and Ctrl+n to have the dialog box, no need to press Ctrl+Alt (with Alt, it types Polish letters into a text box, along with showing the dialog box).

Additionally, I noticed that pressing Ctrl+s launches Save Quizz window. It's ok, just noticed it. No other Ctrl+letter hotkey works.


Profile profile test

Posted: Tue Jun 28, 2011 1:05 pm   Post subject: Re: How to disable hotkeys the same as language-specific letters

Thank you for the detailed description. I have forwarded the issue to our development department for additional research.

It seems that the reason is that iSpring quizbuilder has its own hot keys realization, which can be different from the MS Windows realization. This is why the combination “Alt+Ctrl+n/o” is considered as “Alt+n/o”.

We understand that it is not convenient if the hot keys are used frequently. We have finally managed to fix this issue in the new build of iSpring QuizMaker: now the standard MS Windows hot keys (e.g. "Ctrl+S") won't work if Alt is used (e.g. "Alt+Ctrl+S").

Please download the fixed version of iSpring QuizMaker here:
http://www.ispringsolutions.com/download/beta/ispring_quizmaker_5_7_0_3065.msi


Profile profile test
Display posts from previous:  Sort by  

  


Who is online
Who is online In total there are 7 users online :: 3 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 108 on Thu Nov 21, 2013 3:41 pm

Registered users: Bing [Bot], Google [Bot], Yahoo [Bot]


cron