Author Message

Posted: Mon Jul 27, 2009 4:23 pm   Post subject: SWF not playing in some browsers

Hi, I have a SWF created with PowerPoint 2007 + iSpring Free and embedded in a web page that is not playing/displaying in some browsers. You can see the page here: http://softball.bc.ca

Attached below is the code I used (cut from the FAQ on this site) to insert the movie. Below that is the testing I've done on different platforms; I made sure I installed both Flash Player and Shockwave Player.

Is there something wrong with the embed code I'm using?
Is there some other dependency on the browser side (Javascript version)?
Is there an iSpring flag/switch that needs to be set when converting the PPT file to make the SWF more compatible?
Or is there some limitation to iSpring Free that's causing this?

Thanks for any help (even testing the page and posting whether it works for you would be much appreciated),
Roland

Code:
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
        codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0"
        id="presentation"
        width="450"
        height="375"
        align="">
        <param name="allowScriptAccess" value="sameDomain" />
        <param name="movie" value="FrontPageSlideShow.swf" />
        <param name="quality" value="high" />
        <param name="bgcolor" value="#ffffff" />
        <embed src="FrontPageSlideShow.swf"
               name="presentation"
               quality="high"
               bgcolor="#ffffff"
               width="450"
               height="375"
               align=""
               allowScriptAccess="sameDomain"
               type="application/x-shockwave-flash"
               pluginspage="http://www.macromedia.com/go/getflashplayer">
        </embed>
</object>


Testing Results (sorry for the blanks, these come from users)
WinXP Home + IE 7 + Flash 10 = NO
WinXP Home + FF 3 + Flash 10 = NO
WinXP _ + FF _ + Flash 10 = NO
Ubuntu 8.04 + FF 3 + Flash 10 = YES
WinXP Pro + IE 8 + Flash _ = YES
WinXP Pro + FF 3 + Flash _ = YES
WinXP Pro + IE 7 + Flash _ = YES


Profile profile test

Posted: Mon Jul 27, 2009 5:21 pm   Post subject: Re: SWF not playing in some browsers

I tried opening the SWF file directly using a bunch of different media players (VLC, Totem, MPlayer) and none of them could play the movie. One of them gave me the following error message:

Error Message wrote:
Compressed SWF format not supported

Could the compression be causing the browser problem?


Profile profile test
Display posts from previous:  Sort by  

  


Who is online
Who is online In total there are 6 users online :: 1 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 108 on Thu Nov 21, 2013 3:41 pm

Registered users: Bing [Bot]