Author Message

Posted: Fri Oct 19, 2007 9:52 am   Post subject: Command-Line issue

Hello,
I'm trying to use FS Server in command-line mode.
I have to launch the command with php.

Code:
Here is an example :
"C:\Program Files\FlashSpring Server 2\flashspringSE.exe" s -v -la on -sa on 3060-TempFile.ppt 3060-TempFile.swf


If I do this from a command-line prompt, there's no problem, but if I do this from a php script I always get this error :
Code:
Failed to open presentation 3060-TempFile.ppt. in file D:\projects\fs2_1\flashspring\flashspring\FlashSpringSE2\FlashSpring.cpp at line 307


It seems to be a right management problem, but I've try everything, and no success,

Does anybody know a solution for this problem ?

Thank you very much


Profile profile test

Posted: Fri Oct 19, 2007 1:09 pm   Post subject:

All right, I found the solution !!

The problem was in the Component services.
For PowerPoint, I allowed IUSR_TEST as explain in the installation instruction, but in fact, the account used by the function exec() is NETWORK_SERVICES.
So I just had to allow this account for "Local Activation" for PowerPoint Component.

Hope it should help someone in the future.

Greetings

Fabien.


Profile profile test

Posted: Mon Oct 22, 2007 1:45 pm   Post subject:

Hi Fabien,

Thank you for your investigation of FlashSpring Server setup peculiarities. We prepared an article dedicated to this problem. Please take a look.

http://www.flashspring.com/docs/server/ ... setup.html

I will be happy to help with your further questions.

Yours,
Kamilya


Profile profile test
Display posts from previous:  Sort by  

  


Who is online
Who is online In total there are 8 users online :: 1 registered, 0 hidden and 7 guests (based on users active over the past 5 minutes)
Most users ever online was 108 on Thu Nov 21, 2013 3:41 pm

Registered users: Bing [Bot]