Author Message

Posted: Thu Dec 01, 2016 5:20 pm   Post subject: %USER_NAME% no longer shown in Quizmaker 8.5 with HTTP GET

I am using "Automatic Quiz login via HTTP GET" as descript in your support article. Starting with Version 8.5 the Variable %USER_NAME% is not shown in a quiz. In former versions it worked fine. I need this functionality, because only registered students are allowed to take a quiz with no possibility to change their student number within the quiz. Could you please check why the functionality dissapeared in 8.5 and help.

Regards
Siegfried


Profile profile test

Posted: Mon Dec 05, 2016 6:26 pm   Post subject: Re: %USER_NAME% no longer shown in Quizmaker 8.5 with HTTP G

Hello!
Sorry to hear that you're having this issue.
We've tested this functionality with the most recent iSpring Quizmaker 8.5 build and it seems that the problem didn't occur on our end.
Here is an example:
https://cloud.scorm.com/sc/InvitationCo ... 752d4bff99
The user's name was passed via HTTP GET without any issues.
Could you please check if the option Ask for quiz taker's information is enabled in the Quiz Properties?


Profile profile test

Posted: Mon Dec 05, 2016 7:41 pm   Post subject: Re: %USER_NAME% no longer shown in Quizmaker 8.5 with HTTP G

Hi Julia,

thank you for your answer. You are right: When I ask for user information, the user name (out of http get) in the input field at the beginning of a quiz is shown correctly. The problem comes, when in „Quiz Properties“ I deactivate the checkbox „Ask for user information“. Then within the html5 web quiz the variable „%USER_NAME“ shows the literal „%USER_NAME“ but not the username itself. In your blog article on this topic, it is said, that deactivating the checkbox should work and up to Quizmaker 8.3 it did. It even works now, when I replace the Quizplayer („player.js“) from Quizmaker 8.5 with the older player from Quizmaker 8.3. But with the 8.5-player the username isn't shown.

I need this functionality to prevent cheating. My students should see, if they are logged in with their correct student number, but they shouldn’t be able to use the student number from another student. Therefore i have to deactivate the option "Ask for user information".

Hope that you understand my problem. Thank you and regards
Siegfried


Profile profile test

Posted: Mon Dec 12, 2016 9:08 pm   Post subject: Re: %USER_NAME% no longer shown in Quizmaker 8.5 with HTTP G

Thank you for the detailed description, Siegfried!
I can see that you're also working with one of my colleagues on that issue.
The developers are working on the issue and we'll keep you posted on the progress!


Profile profile test

Posted: Thu Dec 22, 2016 2:24 pm   Post subject: Re: %USER_NAME% no longer shown in Quizmaker 8.5 with HTTP G

With Update 8.5.1 the Problem was solved. Thank You very much for your assistance and promot reaction,


Profile profile test

Posted: Thu Dec 22, 2016 2:58 pm   Post subject: Re: %USER_NAME% no longer shown in Quizmaker 8.5 with HTTP G

@SiegfriedS
Thanks for verifying that the issue is resolved!
We are always happy to assist!


Profile profile test
Display posts from previous:  Sort by  

  


Who is online
Who is online In total there are 18 users online :: 3 registered, 0 hidden and 15 guests (based on users active over the past 5 minutes)
Most users ever online was 143 on Sun Mar 31, 2019 2:07 pm

Registered users: Bing [Bot], Google [Bot], Majestic-12 [Bot]