Author Message

Posted: Tue Jul 24, 2012 3:18 pm   Post subject: Failed to Open Presentation

I have been using iSpring for a while and have never had this kind of issue before. But we recently purchased iSpringSDK Platform 6 and now I am having trouble. Every time I try to convert a powerpoint it gives me the Failed to open presentation...Unspecified Error. This was happening during my PHP conversion. So I tried to run the conversion just through the command line and and even using the sample .bat file that was provided and got the same thing.

I opened the cmd.exe as Administrator to make sure that wasn't the problem and still got the same problem I searched the forum and found an answer to make sure the Desktop folder was under the systemprofile. I checked that and it is. Here is my setup

Windows 7 Professional 32 bit(Desktop folder is under C:\Windows\system32\config\systemprofile)

iSpringSDK Platform 6

Powerpoint 2007

I just cant figure this one out so any help would be greatly appreciated.

Profile profile test

Posted: Wed Jul 25, 2012 11:05 pm   Post subject: Re: Failed to Open Presentation

Please contact us at support email because SDK/Platform issues are very specific and generally related to the config of your server.

Profile profile test

Posted: Mon Jul 30, 2012 5:00 am   Post subject: Re: Failed to Open Presentation

I figured out the problem. It ended up being two problems. First I reinstalled Microsoft Office to make sure I had the VBA installed. I must not have because once I did that the sample php file and the sample .bat file worked fine. But my web application was still not working. After digging through the iSpring documentation and looking at the sample php file I realized the COM object had been changed.

It had changed to "iSpringAS3SDK.PresentationConverter.6" which is much different than what it used to be. So after changing that it seemed to work fine.

There is one problem I was having that I fixed by doing a rename function after the conversion but does the method generateSolidPresentation not allow UNC paths?? I tried to pass a path to it but the path I was passing was "\\storage\content\client\xyz\flash" but it wasn't working. If I did "C:\storage\content\client\xyz\flash" it worked just fine. But we have a mapped network drive and an alias setup through apache but for some reason iSpring does not recognize that. Is that intended??

Profile profile test

Posted: Tue Jul 31, 2012 6:25 pm   Post subject: Re: Failed to Open Presentation

Thank you for the update on it. We are glad to hear that you've figured it out. Indeed, AS3 API is significantly different from AS2 and com object names as well.

We haven't limited network access to the files on purpose. It seems that there is some security flaw in your configuration. It's very hard to estimate it without looking at your system so you probably could look forward for remote assistance service.

Profile profile test
Display posts from previous:  Sort by  


Who is online
Who is online In total there are 13 users online :: 1 registered, 0 hidden and 12 guests (based on users active over the past 5 minutes)
Most users ever online was 803 on Sat Dec 12, 2020 9:21 am

Registered users: Bing [Bot]